summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-orphan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-conffile-orphan/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/t-conffile-orphan/Makefile b/tests/t-conffile-orphan/Makefile
new file mode 100644
index 0000000..1f51ccb
--- /dev/null
+++ b/tests/t-conffile-orphan/Makefile
@@ -0,0 +1,14 @@
+TESTS_DEB := pkg-conff-orphan-0 pkg-conff-orphan-1 pkg-conff-takeover
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-conff-orphan-0.deb
+ $(DPKG_INSTALL) pkg-conff-orphan-1.deb
+ # test if the other package can takeover the orphan conffile
+ $(DPKG_INSTALL) pkg-conff-takeover.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-orphan
+ $(DPKG_PURGE) pkg-conff-takeover
+