summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-prompt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-conffile-prompt/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/t-conffile-prompt/Makefile b/tests/t-conffile-prompt/Makefile
new file mode 100644
index 0000000..1f413bb
--- /dev/null
+++ b/tests/t-conffile-prompt/Makefile
@@ -0,0 +1,20 @@
+TESTS_DEB := pkg-conff-prompt-0 pkg-conff-prompt-1
+
+include ../Test.mk
+
+build-hook:
+ touch "pkg-conff-prompt-0/test-conffile with spaces"
+ touch "pkg-conff-prompt-1/test-conffile with spaces"
+
+clean-hook:
+ $(RM) "pkg-conff-prompt-0/test-conffile with spaces"
+ $(RM) "pkg-conff-prompt-1/test-conffile with spaces"
+
+test-case:
+ $(DPKG_INSTALL) pkg-conff-prompt-0.deb
+ # test if package prompts on install
+ $(DPKG_INSTALL) pkg-conff-prompt-1.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-prompt
+