summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-prompt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-conffile-prompt')
-rw-r--r--tests/t-conffile-prompt/Makefile20
-rw-r--r--tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/conffiles2
-rw-r--r--tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/control8
-rwxr-xr-xtests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/postinst3
-rw-r--r--tests/t-conffile-prompt/pkg-conff-prompt-0/test-conffile1
-rw-r--r--tests/t-conffile-prompt/pkg-conff-prompt-1/DEBIAN/conffiles2
-rw-r--r--tests/t-conffile-prompt/pkg-conff-prompt-1/DEBIAN/control8
-rw-r--r--tests/t-conffile-prompt/pkg-conff-prompt-1/test-conffile1
8 files changed, 45 insertions, 0 deletions
diff --git a/tests/t-conffile-prompt/Makefile b/tests/t-conffile-prompt/Makefile
new file mode 100644
index 0000000..1f413bb
--- /dev/null
+++ b/tests/t-conffile-prompt/Makefile
@@ -0,0 +1,20 @@
+TESTS_DEB := pkg-conff-prompt-0 pkg-conff-prompt-1
+
+include ../Test.mk
+
+build-hook:
+ touch "pkg-conff-prompt-0/test-conffile with spaces"
+ touch "pkg-conff-prompt-1/test-conffile with spaces"
+
+clean-hook:
+ $(RM) "pkg-conff-prompt-0/test-conffile with spaces"
+ $(RM) "pkg-conff-prompt-1/test-conffile with spaces"
+
+test-case:
+ $(DPKG_INSTALL) pkg-conff-prompt-0.deb
+ # test if package prompts on install
+ $(DPKG_INSTALL) pkg-conff-prompt-1.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-prompt
+
diff --git a/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/conffiles b/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/conffiles
new file mode 100644
index 0000000..ef41b42
--- /dev/null
+++ b/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/conffiles
@@ -0,0 +1,2 @@
+/test-conffile
+/test-conffile with spaces
diff --git a/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/control b/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/control
new file mode 100644
index 0000000..3aeb1b2
--- /dev/null
+++ b/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-conff-prompt
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - conffile prompt
+
diff --git a/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/postinst b/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/postinst
new file mode 100755
index 0000000..27be638
--- /dev/null
+++ b/tests/t-conffile-prompt/pkg-conff-prompt-0/DEBIAN/postinst
@@ -0,0 +1,3 @@
+#!/bin/sh
+echo "test modified" >"$DPKG_ROOT/test-conffile"
+echo "test modified spaces" >"$DPKG_ROOT/test-conffile with spaces"
diff --git a/tests/t-conffile-prompt/pkg-conff-prompt-0/test-conffile b/tests/t-conffile-prompt/pkg-conff-prompt-0/test-conffile
new file mode 100644
index 0000000..6fbc8b5
--- /dev/null
+++ b/tests/t-conffile-prompt/pkg-conff-prompt-0/test-conffile
@@ -0,0 +1 @@
+test init
diff --git a/tests/t-conffile-prompt/pkg-conff-prompt-1/DEBIAN/conffiles b/tests/t-conffile-prompt/pkg-conff-prompt-1/DEBIAN/conffiles
new file mode 100644
index 0000000..ef41b42
--- /dev/null
+++ b/tests/t-conffile-prompt/pkg-conff-prompt-1/DEBIAN/conffiles
@@ -0,0 +1,2 @@
+/test-conffile
+/test-conffile with spaces
diff --git a/tests/t-conffile-prompt/pkg-conff-prompt-1/DEBIAN/control b/tests/t-conffile-prompt/pkg-conff-prompt-1/DEBIAN/control
new file mode 100644
index 0000000..8bd3f1e
--- /dev/null
+++ b/tests/t-conffile-prompt/pkg-conff-prompt-1/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-conff-prompt
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - conffile prompt
+
diff --git a/tests/t-conffile-prompt/pkg-conff-prompt-1/test-conffile b/tests/t-conffile-prompt/pkg-conff-prompt-1/test-conffile
new file mode 100644
index 0000000..35f4da8
--- /dev/null
+++ b/tests/t-conffile-prompt/pkg-conff-prompt-1/test-conffile
@@ -0,0 +1 @@
+test end