summaryrefslogtreecommitdiffstats
path: root/tests/t-conffile-replaces-upgrade
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-conffile-replaces-upgrade')
-rw-r--r--tests/t-conffile-replaces-upgrade/Makefile58
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-original/DEBIAN/conffiles2
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-original/DEBIAN/control8
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-original/test-conffile1
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-original/test-confpath1
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-original/test-original0
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/DEBIAN/conffiles2
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/DEBIAN/control9
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-conffile1
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-confpath1
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-takeover0
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/DEBIAN/conffiles2
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/DEBIAN/control9
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-conffile1
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-confpath1
-rw-r--r--tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-takeover0
-rw-r--r--tests/t-conffile-replaces-upgrade/ref-conffile1
17 files changed, 97 insertions, 0 deletions
diff --git a/tests/t-conffile-replaces-upgrade/Makefile b/tests/t-conffile-replaces-upgrade/Makefile
new file mode 100644
index 0000000..88298b3
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/Makefile
@@ -0,0 +1,58 @@
+TESTS_DEB := pkg-conff-original pkg-conff-takeover-0 pkg-conff-takeover-1
+
+include ../Test.mk
+
+TEST_CASES += test-two-run-ordered
+TEST_CASES += test-one-run-ordered
+TEST_CASES += test-two-run-reverse
+TEST_CASES += test-one-run-reverse
+
+test-case: $(TEST_CASES)
+
+define CONFFILES
+$(DPKG_QUERY) -f '$${Package} @ $${Conffiles}\n'
+endef
+
+define VERIFY
+$(call pkg_is_installed,pkg-conff-original)
+$(call pkg_is_installed,pkg-conff-takeover)
+test "`$(DPKG_QUERY) -S /test-conffile`" = "pkg-conff-takeover: /test-conffile"
+test "`$(DPKG_QUERY) -S /test-confpath`" = "pkg-conff-takeover: /test-confpath"
+test "`$(CONFFILES) -W pkg-conff-original | grep obsolete | wc -l`" = "2"
+test "`$(CONFFILES) -W pkg-conff-takeover | grep -v obsolete | wc -l`" = "2"
+cmp ref-conffile "$(DPKG_INSTDIR)/test-conffile"
+cmp ref-conffile "$(DPKG_INSTDIR)/test-confpath"
+endef
+
+test-two-run-ordered:
+ # test-two-run-ordered
+ $(DPKG_INSTALL) pkg-conff-original.deb
+ $(DPKG_INSTALL) pkg-conff-takeover-0.deb
+ $(DPKG_INSTALL) pkg-conff-takeover-1.deb
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
+
+test-one-run-ordered:
+ # test-one-run-ordered
+ $(DPKG_INSTALL) pkg-conff-original.deb pkg-conff-takeover-0.deb
+ $(DPKG_INSTALL) pkg-conff-takeover-1.deb
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
+
+test-two-run-reverse:
+ # test-two-run-reverse
+ $(DPKG_INSTALL) pkg-conff-takeover-0.deb
+ $(DPKG_INSTALL) pkg-conff-original.deb
+ $(DPKG_INSTALL) pkg-conff-takeover-1.deb
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
+
+test-one-run-reverse:
+ # test-one-run-reverse
+ $(DPKG_INSTALL) pkg-conff-takeover-0.deb pkg-conff-original.deb
+ $(DPKG_INSTALL) pkg-conff-takeover-1.deb
+ $(VERIFY)
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
+
+test-clean:
+ $(DPKG_PURGE) pkg-conff-original pkg-conff-takeover
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-original/DEBIAN/conffiles b/tests/t-conffile-replaces-upgrade/pkg-conff-original/DEBIAN/conffiles
new file mode 100644
index 0000000..da14206
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-original/DEBIAN/conffiles
@@ -0,0 +1,2 @@
+/test-conffile
+/test-confpath
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-original/DEBIAN/control b/tests/t-conffile-replaces-upgrade/pkg-conff-original/DEBIAN/control
new file mode 100644
index 0000000..523e417
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-original/DEBIAN/control
@@ -0,0 +1,8 @@
+Package: pkg-conff-original
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - provide a conffile
+
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-conffile b/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-conffile
new file mode 100644
index 0000000..995e78d
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-conffile
@@ -0,0 +1 @@
+test original 0
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-confpath b/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-confpath
new file mode 100644
index 0000000..995e78d
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-confpath
@@ -0,0 +1 @@
+test original 0
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-original b/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-original
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-original/test-original
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/DEBIAN/conffiles b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/DEBIAN/conffiles
new file mode 100644
index 0000000..da14206
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/DEBIAN/conffiles
@@ -0,0 +1,2 @@
+/test-conffile
+/test-confpath
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/DEBIAN/control b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/DEBIAN/control
new file mode 100644
index 0000000..1f1e038
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/DEBIAN/control
@@ -0,0 +1,9 @@
+Package: pkg-conff-takeover
+Version: 0
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Replaces: pkg-conff-original
+Description: test package - conffile replaces takeover
+
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-conffile b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-conffile
new file mode 100644
index 0000000..01c117f
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-conffile
@@ -0,0 +1 @@
+test takeover 0
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-confpath b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-confpath
new file mode 100644
index 0000000..01c117f
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-confpath
@@ -0,0 +1 @@
+test takeover 0
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-takeover b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-takeover
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-0/test-takeover
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/DEBIAN/conffiles b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/DEBIAN/conffiles
new file mode 100644
index 0000000..da14206
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/DEBIAN/conffiles
@@ -0,0 +1,2 @@
+/test-conffile
+/test-confpath
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/DEBIAN/control b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/DEBIAN/control
new file mode 100644
index 0000000..f323304
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/DEBIAN/control
@@ -0,0 +1,9 @@
+Package: pkg-conff-takeover
+Version: 1
+Section: test
+Priority: extra
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Replaces: pkg-conff-original
+Description: test package - conffile replaces takeover
+
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-conffile b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-conffile
new file mode 100644
index 0000000..1bc4643
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-conffile
@@ -0,0 +1 @@
+test takeover 1
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-confpath b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-confpath
new file mode 100644
index 0000000..1bc4643
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-confpath
@@ -0,0 +1 @@
+test takeover 1
diff --git a/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-takeover b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-takeover
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/pkg-conff-takeover-1/test-takeover
diff --git a/tests/t-conffile-replaces-upgrade/ref-conffile b/tests/t-conffile-replaces-upgrade/ref-conffile
new file mode 100644
index 0000000..1bc4643
--- /dev/null
+++ b/tests/t-conffile-replaces-upgrade/ref-conffile
@@ -0,0 +1 @@
+test takeover 1