summaryrefslogtreecommitdiffstats
path: root/tests/t-conflict-provide-replace-real/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-conflict-provide-replace-real/Makefile')
-rw-r--r--tests/t-conflict-provide-replace-real/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/t-conflict-provide-replace-real/Makefile b/tests/t-conflict-provide-replace-real/Makefile
new file mode 100644
index 0000000..84334ce
--- /dev/null
+++ b/tests/t-conflict-provide-replace-real/Makefile
@@ -0,0 +1,13 @@
+TESTS_DEB := pkg-a pkg-b
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-a.deb
+ # test if the replacing package takes over on install
+ $(DPKG_INSTALL) pkg-b.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-b
+ -$(DPKG_PURGE) pkg-a
+