summaryrefslogtreecommitdiffstats
path: root/tests/t-dir-leftover-deadlock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-dir-leftover-deadlock/Makefile')
-rw-r--r--tests/t-dir-leftover-deadlock/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/t-dir-leftover-deadlock/Makefile b/tests/t-dir-leftover-deadlock/Makefile
new file mode 100644
index 0000000..e0f381f
--- /dev/null
+++ b/tests/t-dir-leftover-deadlock/Makefile
@@ -0,0 +1,17 @@
+TESTS_DEB := pkg-dir-shared-0 pkg-dir-shared-1
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-dir-shared-0.deb
+ $(DPKG_INSTALL) pkg-dir-shared-1.deb
+ $(DPKG_REMOVE) pkg-dir-shared-1
+ $(DPKG_REMOVE) pkg-dir-shared-0
+ $(DPKG_PURGE) pkg-dir-shared-0
+ $(DPKG_PURGE) pkg-dir-shared-1
+ test ! -d '$(DPKG_INSTDIR)/test-dir'
+
+test-clean:
+ $(DPKG_PURGE) pkg-dir-shared-0
+ $(DPKG_PURGE) pkg-dir-shared-1
+ $(BEROOT) rm -rf '$(DPKG_INSTDIR)/test-dir'