summaryrefslogtreecommitdiffstats
path: root/tests/t-dir-leftover-parents/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-dir-leftover-parents/Makefile')
-rw-r--r--tests/t-dir-leftover-parents/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/t-dir-leftover-parents/Makefile b/tests/t-dir-leftover-parents/Makefile
new file mode 100644
index 0000000..35e2718
--- /dev/null
+++ b/tests/t-dir-leftover-parents/Makefile
@@ -0,0 +1,16 @@
+TESTS_DEB := pkg-dir-shared pkg-dir-shared-notempty
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-dir-shared.deb
+ $(DPKG_INSTALL) pkg-dir-shared-notempty.deb
+ $(DPKG_REMOVE) pkg-dir-shared-notempty
+ $(DPKG_PURGE) pkg-dir-shared
+ $(DPKG_PURGE) pkg-dir-shared-notempty
+ test ! -d "$(DPKG_INSTDIR)/test-dir"
+
+test-clean:
+ $(DPKG_PURGE) pkg-dir-shared
+ $(DPKG_PURGE) pkg-dir-shared-notempty
+ $(BEROOT) rm -rf "$(DPKG_INSTDIR)/test-dir"