summaryrefslogtreecommitdiffstats
path: root/tests/t-disappear-depended/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-disappear-depended/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/t-disappear-depended/Makefile b/tests/t-disappear-depended/Makefile
new file mode 100644
index 0000000..f7b8362
--- /dev/null
+++ b/tests/t-disappear-depended/Makefile
@@ -0,0 +1,21 @@
+TESTS_DEB := pkg-normal pkg-depend pkg-disappear
+
+include ../Test.mk
+
+test-case:
+ # test disappearing depended package
+ $(DPKG_INSTALL) pkg-disappear.deb
+ $(DPKG_INSTALL) pkg-depend.deb
+ $(DPKG_INSTALL) pkg-normal.deb
+ # should not disappear while it's being depended on
+ $(call pkg_is_installed,pkg-disappear)
+ $(DPKG_PURGE) pkg-depend
+ $(DPKG_INSTALL) pkg-normal.deb
+ # should have been disappered now
+ $(call pkg_is_not_installed,pkg-disappear)
+
+test-clean:
+ -$(DPKG_PURGE) pkg-depend
+ -$(DPKG_PURGE) pkg-disappear
+ $(DPKG_PURGE) pkg-normal
+