summaryrefslogtreecommitdiffstats
path: root/tests/t-disappear-empty/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-disappear-empty/Makefile')
-rw-r--r--tests/t-disappear-empty/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/t-disappear-empty/Makefile b/tests/t-disappear-empty/Makefile
new file mode 100644
index 0000000..66d5c3f
--- /dev/null
+++ b/tests/t-disappear-empty/Makefile
@@ -0,0 +1,16 @@
+TESTS_DEB := pkg-normal pkg-disappear-0 pkg-disappear-1
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-disappear-0.deb
+ # test that an upgraded empty package does not get disappeared
+ $(DPKG_INSTALL) pkg-disappear-1.deb
+ $(call pkg_is_installed,pkg-disappear)
+ $(DPKG_INSTALL) pkg-normal.deb
+ $(call pkg_is_installed,pkg-normal)
+
+test-clean:
+ $(DPKG_PURGE) pkg-disappear
+ $(DPKG_PURGE) pkg-normal
+