summaryrefslogtreecommitdiffstats
path: root/tests/t-field-priority/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-field-priority/Makefile')
-rw-r--r--tests/t-field-priority/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t-field-priority/Makefile b/tests/t-field-priority/Makefile
new file mode 100644
index 0000000..08239e7
--- /dev/null
+++ b/tests/t-field-priority/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := pkg-priority
+
+include ../Test.mk
+
+test-case:
+ # test for unknown priority values
+ $(DPKG_INSTALL) pkg-priority.deb
+ $(call pkg_is_installed,pkg-priority)
+ $(call pkg_field_is,pkg-priority,Priority,value not known)
+
+test-clean:
+ $(DPKG_PURGE) pkg-priority