summaryrefslogtreecommitdiffstats
path: root/tests/t-field-priority
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-field-priority')
-rw-r--r--tests/t-field-priority/Makefile12
-rw-r--r--tests/t-field-priority/pkg-priority/DEBIAN/control7
2 files changed, 19 insertions, 0 deletions
diff --git a/tests/t-field-priority/Makefile b/tests/t-field-priority/Makefile
new file mode 100644
index 0000000..08239e7
--- /dev/null
+++ b/tests/t-field-priority/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := pkg-priority
+
+include ../Test.mk
+
+test-case:
+ # test for unknown priority values
+ $(DPKG_INSTALL) pkg-priority.deb
+ $(call pkg_is_installed,pkg-priority)
+ $(call pkg_field_is,pkg-priority,Priority,value not known)
+
+test-clean:
+ $(DPKG_PURGE) pkg-priority
diff --git a/tests/t-field-priority/pkg-priority/DEBIAN/control b/tests/t-field-priority/pkg-priority/DEBIAN/control
new file mode 100644
index 0000000..f06c05c
--- /dev/null
+++ b/tests/t-field-priority/pkg-priority/DEBIAN/control
@@ -0,0 +1,7 @@
+Package: pkg-priority
+Version: 0.0-1
+Section: test
+Priority: value not known
+Maintainer: Dpkg Developers <debian-dpkg@lists.debian.org>
+Architecture: all
+Description: test package - unknown priority value