summaryrefslogtreecommitdiffstats
path: root/tests/t-queue-process-deconf-dupe/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tests/t-queue-process-deconf-dupe/Makefile')
-rw-r--r--tests/t-queue-process-deconf-dupe/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/t-queue-process-deconf-dupe/Makefile b/tests/t-queue-process-deconf-dupe/Makefile
new file mode 100644
index 0000000..4524936
--- /dev/null
+++ b/tests/t-queue-process-deconf-dupe/Makefile
@@ -0,0 +1,12 @@
+TESTS_DEB := pkg-a-0 pkg-a-1 pkg-b
+
+include ../Test.mk
+
+DPKG_OPTIONS += --auto-deconfigure
+
+test-case:
+ $(DPKG_INSTALL) pkg-a-0.deb
+ $(DPKG_INSTALL) pkg-b.deb pkg-a-1.deb
+
+test-clean:
+ $(DPKG_PURGE) pkg-b pkg-a