summaryrefslogtreecommitdiffstats
path: root/tests/t-verify/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/t-verify/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/t-verify/Makefile b/tests/t-verify/Makefile
new file mode 100644
index 0000000..2763e84
--- /dev/null
+++ b/tests/t-verify/Makefile
@@ -0,0 +1,13 @@
+TESTS_DEB := pkg-verify
+
+include ../Test.mk
+
+test-case:
+ $(DPKG_INSTALL) pkg-verify.deb
+ $(call pkg_is_installed,pkg-verify)
+ $(call stdout_is,$(DPKG_VERIFY) pkg-verify,)
+ $(BEROOT) sh -c "echo 'MODIFIED' >>'$(DPKG_INSTDIR)/test-dir/test-data'"
+ $(call stdout_has,$(DPKG_VERIFY) pkg-verify,^\?\?5\?\?\?\?\?\? /test-dir/test-data$)
+
+test-clean:
+ $(DPKG_PURGE) pkg-verify