summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.library
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:49:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:49:25 +0000
commit464df1d5e5ab1322e2dd0a7796939fff1aeefa9a (patch)
tree6a403684e0978f0287d7f0ec0e5aab1fd31a59e1 /lib/Makefile.library
parentInitial commit. (diff)
downloade2fsprogs-upstream/1.47.0.tar.xz
e2fsprogs-upstream/1.47.0.zip
Adding upstream version 1.47.0.upstream/1.47.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'lib/Makefile.library')
-rw-r--r--lib/Makefile.library27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/Makefile.library b/lib/Makefile.library
new file mode 100644
index 0000000..f78467a
--- /dev/null
+++ b/lib/Makefile.library
@@ -0,0 +1,27 @@
+all:: subdirs $(LIBRARY).a
+
+install-shlibs-strip::
+
+install-shlibs::
+
+uninstall-shlibs::
+
+real-subdirs::
+
+subdirs:: Makefile
+ $(Q) $(MAKE) -s real-subdirs
+ $(Q) touch subdirs
+
+clean::
+ $(Q) $(RM) -f subdirs
+
+$(LIBRARY).a: $(OBJS)
+ $(E) " GEN_LIB $@"
+ $(Q) (if test -r $@; then $(RM) -f $@.bak && $(MV) $@ $@.bak; fi)
+ $(Q) $(ARGEN) $@ $(OBJS)
+ -@$(RANLIB) $@
+ $(Q) $(RM) -f ../$@
+ $(Q) (cd ..; $(LN) $(LINK_BUILD_FLAGS) \
+ `echo $(my_dir) | sed -e 's;lib/;;'`/$@ $@)
+
+$(LIB)/$(LIBRARY).a: $(LIBRARY).a