summaryrefslogtreecommitdiffstats
path: root/browser/base/content/test/tabs/browser_new_tab_url.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /browser/base/content/test/tabs/browser_new_tab_url.js
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--browser/base/content/test/tabs/browser_new_tab_url.js29
1 files changed, 29 insertions, 0 deletions
diff --git a/browser/base/content/test/tabs/browser_new_tab_url.js b/browser/base/content/test/tabs/browser_new_tab_url.js
new file mode 100644
index 0000000000..233cb4e59e
--- /dev/null
+++ b/browser/base/content/test/tabs/browser_new_tab_url.js
@@ -0,0 +1,29 @@
+/* Any copyright is dedicated to the Public Domain.
+ http://creativecommons.org/publicdomain/zero/1.0/ */
+"use strict";
+
+add_task(async function test_browser_open_newtab_default_url() {
+ BrowserOpenTab();
+ const tab = gBrowser.selectedTab;
+
+ if (tab.linkedBrowser.currentURI.spec !== window.BROWSER_NEW_TAB_URL) {
+ // If about:newtab is not loaded immediately, wait for any location change.
+ await BrowserTestUtils.waitForLocationChange(gBrowser);
+ }
+
+ is(tab.linkedBrowser.currentURI.spec, window.BROWSER_NEW_TAB_URL);
+
+ BrowserTestUtils.removeTab(tab);
+});
+
+add_task(async function test_browser_open_newtab_specific_url() {
+ const url = "https://example.com";
+
+ BrowserOpenTab({ url });
+ const tab = gBrowser.selectedTab;
+
+ await BrowserTestUtils.browserLoaded(tab.linkedBrowser);
+ is(tab.linkedBrowser.currentURI.spec, "https://example.com/");
+
+ BrowserTestUtils.removeTab(tab);
+});