summaryrefslogtreecommitdiffstats
path: root/browser/components/urlbar/tests/unit/test_providerPlaces_nonEnglish.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /browser/components/urlbar/tests/unit/test_providerPlaces_nonEnglish.js
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'browser/components/urlbar/tests/unit/test_providerPlaces_nonEnglish.js')
-rw-r--r--browser/components/urlbar/tests/unit/test_providerPlaces_nonEnglish.js43
1 files changed, 43 insertions, 0 deletions
diff --git a/browser/components/urlbar/tests/unit/test_providerPlaces_nonEnglish.js b/browser/components/urlbar/tests/unit/test_providerPlaces_nonEnglish.js
new file mode 100644
index 0000000000..2cb5f5797a
--- /dev/null
+++ b/browser/components/urlbar/tests/unit/test_providerPlaces_nonEnglish.js
@@ -0,0 +1,43 @@
+/* -*- indent-tabs-mode: nil; js-indent-level: 2 -*- */
+/* vim:set ts=2 sw=2 sts=2 et: */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+/*
+
+Test autocomplete for non-English URLs
+
+- add a visit for a page with a non-English URL
+- search
+- test number of matches (should be exactly one)
+
+*/
+
+testEngine_setup();
+
+add_task(async function test_autocomplete_non_english() {
+ Services.prefs.setBoolPref("browser.urlbar.suggest.searches", false);
+ registerCleanupFunction(() => {
+ Services.prefs.clearUserPref("browser.urlbar.suggest.searches");
+ });
+
+ let searchTerm = "ユニコード";
+ let unescaped = "http://www.foobar.com/" + searchTerm + "/";
+ let uri = Services.io.newURI(unescaped);
+ await PlacesTestUtils.addVisits(uri);
+ let context = createContext(searchTerm, { isPrivate: false });
+ await check_results({
+ context,
+ matches: [
+ makeSearchResult(context, {
+ engineName: SUGGESTIONS_ENGINE_NAME,
+ heuristic: true,
+ }),
+ makeVisitResult(context, {
+ uri: uri.spec,
+ title: `test visit for ${uri.spec}`,
+ }),
+ ],
+ });
+});