summaryrefslogtreecommitdiffstats
path: root/build/clang-plugin/tests/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /build/clang-plugin/tests/Makefile.in
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--build/clang-plugin/tests/Makefile.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/build/clang-plugin/tests/Makefile.in b/build/clang-plugin/tests/Makefile.in
new file mode 100644
index 0000000000..318c9a0261
--- /dev/null
+++ b/build/clang-plugin/tests/Makefile.in
@@ -0,0 +1,19 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+$(OBJS): $(CLANG_PLUGIN)
+
+# Because building the objects doesn't actually build anything, create
+# a stamp file to avoid re-running the tests unless the test files or
+# the plugin changed. And since no objects are created, and not having
+# the files around makes the rule always, we create dummy files here too.
+tests-ok: $(OBJS) $(CSRCS) $(CPPSRCS) $(CLANG_PLUGIN)
+ touch $@ $(OBJS)
+
+target-objects: tests-ok
+
+# Don't actually build a library, since we don't actually build objects.
+$(LIBRARY): EXPAND_LIBS_GEN=true