summaryrefslogtreecommitdiffstats
path: root/debian/dh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:34:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:34:35 +0000
commit63de81373e18709bf3cf805a9aea810d7105be62 (patch)
tree381c798425ec7b9d4634609f0ac776a4b3e7e309 /debian/dh
parentAdding upstream version 115.7.0esr. (diff)
downloadfirefox-esr-63de81373e18709bf3cf805a9aea810d7105be62.tar.xz
firefox-esr-63de81373e18709bf3cf805a9aea810d7105be62.zip
Adding debian version 115.7.0esr-1~deb12u1.debian/115.7.0esr-1_deb12u1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/dh')
-rwxr-xr-xdebian/dh25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/dh b/debian/dh
new file mode 100755
index 0000000000..5b43536dd4
--- /dev/null
+++ b/debian/dh
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# Wrapper around dh to enable parallelism in debian/rules if not already
+# enabled.
+
+case "$MAKEFLAGS" in
+*-j*)
+ # Already enabled, do nothing.
+ ;;
+*)
+ parallel=
+ for opt in "$DEB_BUILD_OPTIONS"; do
+ case "$opt" in
+ parallel=*)
+ parallel=${opt#parallel=}
+ ;;
+ esac
+ done
+ if [ -n "$parallel" ]; then
+ export MAKEFLAGS="-j$parallel${MAKEFLAGS:+ $MAKEFLAGS}"
+ fi
+ ;;
+esac
+
+exec dh "$@"