summaryrefslogtreecommitdiffstats
path: root/dom/webidl/WritableStream.webidl
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /dom/webidl/WritableStream.webidl
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--dom/webidl/WritableStream.webidl25
1 files changed, 25 insertions, 0 deletions
diff --git a/dom/webidl/WritableStream.webidl b/dom/webidl/WritableStream.webidl
new file mode 100644
index 0000000000..b368de8057
--- /dev/null
+++ b/dom/webidl/WritableStream.webidl
@@ -0,0 +1,25 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#ws-class-definition
+ */
+
+[Exposed=*] // [Transferable] - See Bug 1562065
+interface WritableStream {
+ [Throws]
+ constructor(optional object underlyingSink, optional QueuingStrategy strategy = {});
+
+ readonly attribute boolean locked;
+
+ [Throws]
+ Promise<undefined> abort(optional any reason);
+
+ [NewObject]
+ Promise<undefined> close();
+
+ [Throws]
+ WritableStreamDefaultWriter getWriter();
+};