summaryrefslogtreecommitdiffstats
path: root/extensions/spellcheck/hunspell/update.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /extensions/spellcheck/hunspell/update.sh
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xextensions/spellcheck/hunspell/update.sh34
1 files changed, 34 insertions, 0 deletions
diff --git a/extensions/spellcheck/hunspell/update.sh b/extensions/spellcheck/hunspell/update.sh
new file mode 100755
index 0000000000..5bed8cfb12
--- /dev/null
+++ b/extensions/spellcheck/hunspell/update.sh
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+if [ $# -lt 1 ]; then
+ echo update.sh "<release tag name>"
+ exit 1
+fi
+
+hunspell_dir=`dirname $0`
+
+tmpclonedir=$(mktemp -d)
+git clone https://github.com/hunspell/hunspell --depth 1 --branch $1 ${tmpclonedir}
+# Back up mozilla files
+cp ${hunspell_dir}/src/moz.build ${tmpclonedir}/src/hunspell
+cp ${hunspell_dir}/src/moz.yaml ${tmpclonedir}/src/hunspell
+cp ${hunspell_dir}/src/sources.mozbuild ${tmpclonedir}/src/hunspell
+
+rm -rf ${hunspell_dir}/src
+cp -r ${tmpclonedir}/src/hunspell/ ${hunspell_dir}/src
+cp ${tmpclonedir}/license.hunspell ${hunspell_dir}/src
+cp ${tmpclonedir}/license.myspell ${hunspell_dir}/src
+cp ${tmpclonedir}/README.md ${hunspell_dir}/src
+rm ${hunspell_dir}/src/Makefile.am
+rm ${hunspell_dir}/src/filemgr.cxx
+rm ${hunspell_dir}/src/hunvisapi.h.in
+rm ${hunspell_dir}/src/hunzip.cxx
+rm ${hunspell_dir}/src/hunzip.hxx
+rm ${hunspell_dir}/src/utf_info.hxx
+rm -rf ${tmpclonedir}
+
+cd ${hunspell_dir}/src
+patch -p5 < ../patches/bug1410214.patch
+patch -p5 < ../patches/bug1653659.patch
+patch -p5 < ../patches/bug1739761.patch
+patch -p5 < ../patches/bug1838113.patch