summaryrefslogtreecommitdiffstats
path: root/js/xpconnect/tests/unit/test_subScriptLoader.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /js/xpconnect/tests/unit/test_subScriptLoader.js
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'js/xpconnect/tests/unit/test_subScriptLoader.js')
-rw-r--r--js/xpconnect/tests/unit/test_subScriptLoader.js16
1 files changed, 16 insertions, 0 deletions
diff --git a/js/xpconnect/tests/unit/test_subScriptLoader.js b/js/xpconnect/tests/unit/test_subScriptLoader.js
new file mode 100644
index 0000000000..70301f9da4
--- /dev/null
+++ b/js/xpconnect/tests/unit/test_subScriptLoader.js
@@ -0,0 +1,16 @@
+"use strict";
+
+add_task(async function test_executeScriptAfterNuked() {
+ let scriptUrl = Services.io.newFileURI(do_get_file("file_simple_script.js")).spec;
+
+ // Load the script for the first time into a sandbox, and then nuke
+ // that sandbox.
+ let sandbox = Cu.Sandbox(Services.scriptSecurityManager.getSystemPrincipal());
+ Services.scriptloader.loadSubScript(scriptUrl, sandbox);
+ Cu.nukeSandbox(sandbox);
+
+ // Load the script again into a new sandbox, and make sure it
+ // succeeds.
+ sandbox = Cu.Sandbox(Services.scriptSecurityManager.getSystemPrincipal());
+ Services.scriptloader.loadSubScript(scriptUrl, sandbox);
+});