summaryrefslogtreecommitdiffstats
path: root/media/libvpx/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /media/libvpx/Makefile.in
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--media/libvpx/Makefile.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/media/libvpx/Makefile.in b/media/libvpx/Makefile.in
new file mode 100644
index 0000000000..71baaffdcb
--- /dev/null
+++ b/media/libvpx/Makefile.in
@@ -0,0 +1,24 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+# Set up the libvpx assembler config.
+
+include $(topsrcdir)/config/rules.mk
+
+ifeq ($(CPU_ARCH),arm)
+ifdef GNU_AS
+# The ARM asm is written in ARM RVCT syntax, but we actually build it with
+# gas using GNU syntax. Add some rules to perform the conversion.
+
+# Previously used $(dir $(ASFILES)) to figure out which directories to generate.
+# However, .S (as opposed to .s) files are not added to ASFILES. There is only
+# one directory with arm assembly currently so enumerate it manually.
+GENERATED_DIRS += libvpx/vpx_dsp/arm
+
+libvpx/vpx_dsp/arm/%.asm.S: $(srcdir)/libvpx/vpx_dsp/arm/%.asm $(call mkdir_deps,libvpx/vpx_dsp/arm)
+ $(PERL) $(topsrcdir)/media/libvpx/libvpx/build/make/ads2gas.pl < $< > $@
+
+$(addsuffix .$(OBJ_SUFFIX), idct4x4_add_neon.asm idct8x8_add_neon.asm idct16x16_add_neon.asm): libvpx/vpx_dsp/arm/idct_neon.asm.S
+endif
+endif