summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/.mocharc.cjs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /remote/test/puppeteer/.mocharc.cjs
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'remote/test/puppeteer/.mocharc.cjs')
-rw-r--r--remote/test/puppeteer/.mocharc.cjs27
1 files changed, 27 insertions, 0 deletions
diff --git a/remote/test/puppeteer/.mocharc.cjs b/remote/test/puppeteer/.mocharc.cjs
new file mode 100644
index 0000000000..54fae5d77b
--- /dev/null
+++ b/remote/test/puppeteer/.mocharc.cjs
@@ -0,0 +1,27 @@
+/**
+ * Copyright 2020 Google Inc. All rights reserved.
+ *
+ * Licensed under the Apache License, Version 2.0 (the "License");
+ * you may not use this file except in compliance with the License.
+ * You may obtain a copy of the License at
+ *
+ * http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+
+module.exports = {
+ reporter: 'dot',
+ logLevel: 'debug',
+ require: ['./test/build/mocha-utils.js', 'source-map-support/register'],
+ spec: 'test/build/**/*.spec.js',
+ exit: !!process.env.CI,
+ retries: process.env.CI ? 3 : 0,
+ parallel: !!process.env.PARALLEL,
+ timeout: 10_000,
+ reporter: process.env.CI ? 'spec' : 'dot',
+};