summaryrefslogtreecommitdiffstats
path: root/third_party/jpeg-xl/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/jpeg-xl/debian/rules
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/jpeg-xl/debian/rules')
-rwxr-xr-xthird_party/jpeg-xl/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/third_party/jpeg-xl/debian/rules b/third_party/jpeg-xl/debian/rules
new file mode 100755
index 0000000000..6259dbfc61
--- /dev/null
+++ b/third_party/jpeg-xl/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/pkg-info.mk
+
+%:
+ dh $@ --buildsystem=cmake
+
+override_dh_auto_configure:
+ # TODO(deymo): Remove the DCMAKE_BUILD_TYPE once builds without NDEBUG
+ # are as useful as Release builds.
+ # TODO(szabadka) Re-enable jpegli after tests are fixed on Ubuntu 20.04,
+ # and debian:buster
+ dh_auto_configure -- \
+ -DJPEGXL_VERSION=$(DEB_VERSION) \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DJPEGXL_FORCE_SYSTEM_GTEST=ON \
+ -DJPEGXL_FORCE_SYSTEM_BROTLI=ON \
+ -DJPEGXL_FORCE_SYSTEM_HWY=ON \
+ -DJPEGXL_ENABLE_JPEGLI=OFF \
+ -DJPEGXL_ENABLE_JPEGLI_LIBJPEG=OFF \
+ -DJPEGXL_ENABLE_PLUGINS=ON