summaryrefslogtreecommitdiffstats
path: root/third_party/python/MarkupSafe/src/MarkupSafe.egg-info
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/python/MarkupSafe/src/MarkupSafe.egg-info
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/MarkupSafe/src/MarkupSafe.egg-info')
-rw-r--r--third_party/python/MarkupSafe/src/MarkupSafe.egg-info/PKG-INFO98
-rw-r--r--third_party/python/MarkupSafe/src/MarkupSafe.egg-info/SOURCES.txt34
-rw-r--r--third_party/python/MarkupSafe/src/MarkupSafe.egg-info/dependency_links.txt1
-rw-r--r--third_party/python/MarkupSafe/src/MarkupSafe.egg-info/top_level.txt1
4 files changed, 134 insertions, 0 deletions
diff --git a/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/PKG-INFO b/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/PKG-INFO
new file mode 100644
index 0000000000..bd2f99cba8
--- /dev/null
+++ b/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/PKG-INFO
@@ -0,0 +1,98 @@
+Metadata-Version: 2.1
+Name: MarkupSafe
+Version: 2.0.1
+Summary: Safely add untrusted strings to HTML/XML markup.
+Home-page: https://palletsprojects.com/p/markupsafe/
+Author: Armin Ronacher
+Author-email: armin.ronacher@active-4.com
+Maintainer: Pallets
+Maintainer-email: contact@palletsprojects.com
+License: BSD-3-Clause
+Project-URL: Donate, https://palletsprojects.com/donate
+Project-URL: Documentation, https://markupsafe.palletsprojects.com/
+Project-URL: Changes, https://markupsafe.palletsprojects.com/changes/
+Project-URL: Source Code, https://github.com/pallets/markupsafe/
+Project-URL: Issue Tracker, https://github.com/pallets/markupsafe/issues/
+Project-URL: Twitter, https://twitter.com/PalletsTeam
+Project-URL: Chat, https://discord.gg/pallets
+Description: MarkupSafe
+ ==========
+
+ MarkupSafe implements a text object that escapes characters so it is
+ safe to use in HTML and XML. Characters that have special meanings are
+ replaced so that they display as the actual characters. This mitigates
+ injection attacks, meaning untrusted user input can safely be displayed
+ on a page.
+
+
+ Installing
+ ----------
+
+ Install and update using `pip`_:
+
+ .. code-block:: text
+
+ pip install -U MarkupSafe
+
+ .. _pip: https://pip.pypa.io/en/stable/quickstart/
+
+
+ Examples
+ --------
+
+ .. code-block:: pycon
+
+ >>> from markupsafe import Markup, escape
+
+ >>> # escape replaces special characters and wraps in Markup
+ >>> escape("<script>alert(document.cookie);</script>")
+ Markup('&lt;script&gt;alert(document.cookie);&lt;/script&gt;')
+
+ >>> # wrap in Markup to mark text "safe" and prevent escaping
+ >>> Markup("<strong>Hello</strong>")
+ Markup('<strong>hello</strong>')
+
+ >>> escape(Markup("<strong>Hello</strong>"))
+ Markup('<strong>hello</strong>')
+
+ >>> # Markup is a str subclass
+ >>> # methods and operators escape their arguments
+ >>> template = Markup("Hello <em>{name}</em>")
+ >>> template.format(name='"World"')
+ Markup('Hello <em>&#34;World&#34;</em>')
+
+
+ Donate
+ ------
+
+ The Pallets organization develops and supports MarkupSafe and other
+ popular packages. In order to grow the community of contributors and
+ users, and allow the maintainers to devote more time to the projects,
+ `please donate today`_.
+
+ .. _please donate today: https://palletsprojects.com/donate
+
+
+ Links
+ -----
+
+ - Documentation: https://markupsafe.palletsprojects.com/
+ - Changes: https://markupsafe.palletsprojects.com/changes/
+ - PyPI Releases: https://pypi.org/project/MarkupSafe/
+ - Source Code: https://github.com/pallets/markupsafe/
+ - Issue Tracker: https://github.com/pallets/markupsafe/issues/
+ - Website: https://palletsprojects.com/p/markupsafe/
+ - Twitter: https://twitter.com/PalletsTeam
+ - Chat: https://discord.gg/pallets
+
+Platform: UNKNOWN
+Classifier: Development Status :: 5 - Production/Stable
+Classifier: Environment :: Web Environment
+Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: BSD License
+Classifier: Operating System :: OS Independent
+Classifier: Programming Language :: Python
+Classifier: Topic :: Internet :: WWW/HTTP :: Dynamic Content
+Classifier: Topic :: Text Processing :: Markup :: HTML
+Requires-Python: >=3.6
+Description-Content-Type: text/x-rst
diff --git a/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/SOURCES.txt b/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/SOURCES.txt
new file mode 100644
index 0000000000..3f8c1a146d
--- /dev/null
+++ b/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/SOURCES.txt
@@ -0,0 +1,34 @@
+CHANGES.rst
+LICENSE.rst
+MANIFEST.in
+README.rst
+setup.cfg
+setup.py
+tox.ini
+docs/Makefile
+docs/changes.rst
+docs/conf.py
+docs/escaping.rst
+docs/formatting.rst
+docs/html.rst
+docs/index.rst
+docs/license.rst
+docs/make.bat
+requirements/dev.txt
+requirements/docs.txt
+requirements/tests.txt
+requirements/typing.txt
+src/MarkupSafe.egg-info/PKG-INFO
+src/MarkupSafe.egg-info/SOURCES.txt
+src/MarkupSafe.egg-info/dependency_links.txt
+src/MarkupSafe.egg-info/top_level.txt
+src/markupsafe/__init__.py
+src/markupsafe/_native.py
+src/markupsafe/_speedups.c
+src/markupsafe/_speedups.pyi
+src/markupsafe/py.typed
+tests/conftest.py
+tests/test_escape.py
+tests/test_exception_custom_html.py
+tests/test_leak.py
+tests/test_markupsafe.py \ No newline at end of file
diff --git a/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/dependency_links.txt b/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/dependency_links.txt
new file mode 100644
index 0000000000..8b13789179
--- /dev/null
+++ b/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/dependency_links.txt
@@ -0,0 +1 @@
+
diff --git a/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/top_level.txt b/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/top_level.txt
new file mode 100644
index 0000000000..75bf729258
--- /dev/null
+++ b/third_party/python/MarkupSafe/src/MarkupSafe.egg-info/top_level.txt
@@ -0,0 +1 @@
+markupsafe