summaryrefslogtreecommitdiffstats
path: root/third_party/rust/audioipc2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/audioipc2/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/audioipc2/Cargo.toml')
-rw-r--r--third_party/rust/audioipc2/Cargo.toml82
1 files changed, 82 insertions, 0 deletions
diff --git a/third_party/rust/audioipc2/Cargo.toml b/third_party/rust/audioipc2/Cargo.toml
new file mode 100644
index 0000000000..98de8c77a6
--- /dev/null
+++ b/third_party/rust/audioipc2/Cargo.toml
@@ -0,0 +1,82 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "audioipc2"
+version = "0.5.0"
+authors = [
+ "Matthew Gregan <kinetik@flim.org>",
+ "Dan Glastonbury <dan.glastonbury@gmail.com>",
+]
+description = "Remote Cubeb IPC"
+license = "ISC"
+
+[[bench]]
+name = "serialization"
+harness = false
+
+[dependencies]
+bincode = "1.3"
+byteorder = "1"
+bytes = "1"
+crossbeam-queue = "0.3"
+cubeb = "0.10"
+log = "0.4"
+scopeguard = "1.1.0"
+serde = "1"
+serde_bytes = "0.11"
+serde_derive = "1"
+slab = "0.4"
+
+[dependencies.error-chain]
+version = "0.12.0"
+default-features = false
+
+[dependencies.mio]
+version = "0.8"
+features = [
+ "os-poll",
+ "net",
+ "os-ext",
+]
+
+[dev-dependencies]
+env_logger = "0.9"
+
+[dev-dependencies.criterion]
+version = "0.3"
+features = ["html_reports"]
+
+[build-dependencies]
+cc = "1.0"
+
+[target."cfg(target_os = \"android\")".dependencies]
+ashmem = "0.1.2"
+
+[target."cfg(target_os = \"linux\")".dependencies.audio_thread_priority]
+version = "0.26.1"
+default-features = false
+
+[target."cfg(unix)".dependencies]
+arrayvec = "0.7"
+iovec = "0.1"
+libc = "0.2"
+memmap2 = "0.5"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = [
+ "combaseapi",
+ "handleapi",
+ "memoryapi",
+ "objbase",
+]