summaryrefslogtreecommitdiffstats
path: root/third_party/rust/chardetng/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/chardetng/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/chardetng/Cargo.toml')
-rw-r--r--third_party/rust/chardetng/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/third_party/rust/chardetng/Cargo.toml b/third_party/rust/chardetng/Cargo.toml
new file mode 100644
index 0000000000..4f5110a092
--- /dev/null
+++ b/third_party/rust/chardetng/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "chardetng"
+version = "0.1.9"
+authors = ["Henri Sivonen <hsivonen@hsivonen.fi>"]
+description = "A character encoding detector for legacy Web content"
+homepage = "https://docs.rs/chardetng/"
+documentation = "https://docs.rs/chardetng/"
+readme = "README.md"
+keywords = [
+ "encoding",
+ "web",
+ "unicode",
+ "charset",
+]
+categories = [
+ "text-processing",
+ "encoding",
+ "web-programming",
+ "internationalization",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/hsivonen/chardetng"
+
+[dependencies]
+encoding_rs = "0.8.17"
+memchr = "2.2.0"
+
+[dev-dependencies]
+detone = "1.0.0"
+
+[features]
+testing-only-no-semver-guarantees-do-not-use = []