summaryrefslogtreecommitdiffstats
path: root/third_party/rust/debugid/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/debugid/Makefile
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/debugid/Makefile')
-rw-r--r--third_party/rust/debugid/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/debugid/Makefile b/third_party/rust/debugid/Makefile
new file mode 100644
index 0000000000..f0670799d8
--- /dev/null
+++ b/third_party/rust/debugid/Makefile
@@ -0,0 +1,32 @@
+all: style lint test
+.PHONY: all
+
+check: style lint
+.PHONY: check
+
+build:
+ @cargo build
+.PHONY: build
+
+doc:
+ @cargo doc
+.PHONY: doc
+
+test:
+ @cargo test
+.PHONY: test
+
+style:
+ @rustup component add rustfmt --toolchain stable 2> /dev/null
+ cargo +stable fmt -- --check
+.PHONY: style
+
+format:
+ @rustup component add rustfmt --toolchain stable 2> /dev/null
+ @cargo +stable fmt
+.PHONY: format
+
+lint:
+ @rustup component add clippy --toolchain stable 2> /dev/null
+ @cargo +stable clippy --tests -- -D clippy::all
+.PHONY: lint