summaryrefslogtreecommitdiffstats
path: root/third_party/rust/dogear/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/dogear/README.md
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/dogear/README.md18
1 files changed, 18 insertions, 0 deletions
diff --git a/third_party/rust/dogear/README.md b/third_party/rust/dogear/README.md
new file mode 100644
index 0000000000..751853dcdc
--- /dev/null
+++ b/third_party/rust/dogear/README.md
@@ -0,0 +1,18 @@
+# Dogear
+
+**Dogear** is a library that implements bookmark tree merging for Firefox Sync. It takes two trees—a valid, consistent local tree, and a possibly inconsistent remote tree—and produces a complete merged tree, with all conflicts and inconsistencies resolved.
+
+Dogear implements the merge algorithm only; it doesn't handle syncing, storage, or application. It's up to the crate that embeds Dogear to store local and incoming bookmarks, describe how to build a tree from a storage backend, persist the merged tree back to storage, and upload records for changed bookmarks.
+
+## Requirements
+
+* Rust 1.31.0 or higher
+
+
+## Updating this package
+Once a new version of Dogear is ready to release. The new version will need to be published to [crates.io](https://crates.io/crates/dogear). Dogear follows the documentation detailed in the [Cargo book](https://doc.rust-lang.org/cargo/reference/publishing.html#publishing-a-new-version-of-an-existing-crate).
+### Steps to publish a new verison
+1. Bump the version in the `Cargo.toml` file
+2. Run `cargo publish --dry-run`
+ - Validate it does what you want it to do
+3. Run `cargo publish` and follow the steps cargo provides