summaryrefslogtreecommitdiffstats
path: root/third_party/rust/futures/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/futures/README.md
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/futures/README.md')
-rw-r--r--third_party/rust/futures/README.md61
1 files changed, 61 insertions, 0 deletions
diff --git a/third_party/rust/futures/README.md b/third_party/rust/futures/README.md
new file mode 100644
index 0000000000..45e1f5b320
--- /dev/null
+++ b/third_party/rust/futures/README.md
@@ -0,0 +1,61 @@
+<p align="center">
+ <img alt="futures-rs" src="https://raw.githubusercontent.com/rust-lang/futures-rs/gh-pages/assets/images/futures-rs-logo.svg?sanitize=true" width="400">
+</p>
+
+<p align="center">
+ Zero-cost asynchronous programming in Rust
+</p>
+
+<p align="center">
+ <a href="https://github.com/rust-lang/futures-rs/actions?query=branch%3Amaster">
+ <img alt="Build Status" src="https://img.shields.io/github/actions/workflow/status/rust-lang/futures-rs/ci.yml?branch=master">
+ </a>
+
+ <a href="https://crates.io/crates/futures">
+ <img alt="crates.io" src="https://img.shields.io/crates/v/futures.svg">
+ </a>
+</p>
+
+<p align="center">
+ <a href="https://docs.rs/futures">
+ Documentation
+ </a> | <a href="https://rust-lang.github.io/futures-rs/">
+ Website
+ </a>
+</p>
+
+`futures-rs` is a library providing the foundations for asynchronous programming in Rust.
+It includes key trait definitions like `Stream`, as well as utilities like `join!`,
+`select!`, and various futures combinator methods which enable expressive asynchronous
+control flow.
+
+## Usage
+
+Add this to your `Cargo.toml`:
+
+```toml
+[dependencies]
+futures = "0.3"
+```
+
+The current `futures` requires Rust 1.45 or later.
+
+### Feature `std`
+
+Futures-rs works without the standard library, such as in bare metal environments.
+However, it has a significantly reduced API surface. To use futures-rs in
+a `#[no_std]` environment, use:
+
+```toml
+[dependencies]
+futures = { version = "0.3", default-features = false }
+```
+
+## License
+
+Licensed under either of [Apache License, Version 2.0](LICENSE-APACHE) or
+[MIT license](LICENSE-MIT) at your option.
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in the work by you, as defined in the Apache-2.0 license, shall
+be dual licensed as above, without any additional terms or conditions.