summaryrefslogtreecommitdiffstats
path: root/third_party/rust/jsparagus/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/jsparagus/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/rust/jsparagus/Cargo.toml69
1 files changed, 69 insertions, 0 deletions
diff --git a/third_party/rust/jsparagus/Cargo.toml b/third_party/rust/jsparagus/Cargo.toml
new file mode 100644
index 0000000000..54ef2890c3
--- /dev/null
+++ b/third_party/rust/jsparagus/Cargo.toml
@@ -0,0 +1,69 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "jsparagus"
+version = "0.1.0"
+authors = ["The jsparagus Project Developers"]
+publish = false
+description = "A JavaScript parser"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/mozilla-spidermonkey/jsparagus"
+
+[profile.release]
+debug = true
+
+[lib]
+
+[[bin]]
+name = "smoosh_tools"
+path = "src/bin/smoosh_tools.rs"
+
+[dependencies.jsparagus-ast]
+path = "crates/ast"
+
+[dependencies.jsparagus-driver]
+path = "crates/driver"
+optional = true
+
+[dependencies.jsparagus-emitter]
+path = "crates/emitter"
+
+[dependencies.jsparagus-generated-parser]
+path = "crates/generated_parser"
+
+[dependencies.jsparagus-interpreter]
+path = "crates/interpreter"
+optional = true
+
+[dependencies.jsparagus-json-log]
+path = "crates/json-log"
+
+[dependencies.jsparagus-parser]
+path = "crates/parser"
+
+[dependencies.jsparagus-scope]
+path = "crates/scope"
+
+[dependencies.jsparagus-stencil]
+path = "crates/stencil"
+
+[features]
+default = []
+full = [
+ "jsparagus-driver",
+ "jsparagus-interpreter",
+]
+logging = ["jsparagus-parser/logging"]
+
+[workspace]