summaryrefslogtreecommitdiffstats
path: root/third_party/rust/rkv/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/rkv/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/rkv/Cargo.toml')
-rw-r--r--third_party/rust/rkv/Cargo.toml135
1 files changed, 135 insertions, 0 deletions
diff --git a/third_party/rust/rkv/Cargo.toml b/third_party/rust/rkv/Cargo.toml
new file mode 100644
index 0000000000..8d925c46ef
--- /dev/null
+++ b/third_party/rust/rkv/Cargo.toml
@@ -0,0 +1,135 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.58"
+name = "rkv"
+version = "0.18.4"
+authors = [
+ "Richard Newman <rnewman@twinql.com>",
+ "Nan Jiang <najiang@mozilla.com>",
+ "Myk Melez <myk@mykzilla.org>",
+ "Victor Porof <vporof@mozilla.com>",
+]
+exclude = ["/tests/envs/*"]
+description = "A simple, humane, typed key-value storage solution"
+homepage = "https://github.com/mozilla/rkv"
+documentation = "https://docs.rs/rkv"
+readme = "README.md"
+keywords = [
+ "lmdb",
+ "database",
+ "storage",
+]
+categories = ["database"]
+license = "Apache-2.0"
+repository = "https://github.com/mozilla/rkv"
+
+[[bin]]
+name = "rand"
+path = "src/bin/rand.rs"
+required-features = ["lmdb"]
+
+[[bin]]
+name = "dump"
+path = "src/bin/dump.rs"
+required-features = ["lmdb"]
+
+[[test]]
+name = "env-all"
+required-features = ["lmdb"]
+
+[[test]]
+name = "env-lmdb"
+required-features = ["lmdb"]
+
+[[test]]
+name = "env-migration"
+required-features = ["lmdb"]
+
+[dependencies.arrayref]
+version = "0.3"
+
+[dependencies.bincode]
+version = "1.0"
+
+[dependencies.bitflags]
+version = "1.2"
+
+[dependencies.byteorder]
+version = "1"
+
+[dependencies.id-arena]
+version = "2.2"
+
+[dependencies.lazy_static]
+version = "1.1"
+
+[dependencies.lmdb-rkv]
+version = "0.14"
+optional = true
+
+[dependencies.log]
+version = "0.4.4"
+
+[dependencies.ordered-float]
+version = "3.0.0"
+
+[dependencies.paste]
+version = "1.0.6"
+
+[dependencies.serde]
+version = "1.0.144"
+features = [
+ "derive",
+ "rc",
+]
+
+[dependencies.serde_derive]
+version = "1.0"
+
+[dependencies.thiserror]
+version = "1.0"
+
+[dependencies.url]
+version = "2.0"
+
+[dependencies.uuid]
+version = "1.0"
+
+[dev-dependencies.byteorder]
+version = "1"
+
+[dev-dependencies.tempfile]
+version = "3"
+
+[features]
+db-dup-sort = []
+db-int-key = []
+default = [
+ "db-dup-sort",
+ "db-int-key",
+]
+lmdb = ["lmdb-rkv"]
+no-canonicalize-path = []
+with-asan = [
+ "lmdb",
+ "lmdb-rkv/with-asan",
+]
+with-fuzzer = [
+ "lmdb",
+ "lmdb-rkv/with-fuzzer",
+]
+with-fuzzer-no-link = [
+ "lmdb",
+ "lmdb-rkv/with-fuzzer-no-link",
+]