summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/serde/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/serde/Cargo.toml')
-rw-r--r--third_party/rust/serde/Cargo.toml70
1 files changed, 70 insertions, 0 deletions
diff --git a/third_party/rust/serde/Cargo.toml b/third_party/rust/serde/Cargo.toml
new file mode 100644
index 0000000000..93acff3a2a
--- /dev/null
+++ b/third_party/rust/serde/Cargo.toml
@@ -0,0 +1,70 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+rust-version = "1.13"
+name = "serde"
+version = "1.0.152"
+authors = [
+ "Erick Tryzelaar <erick.tryzelaar@gmail.com>",
+ "David Tolnay <dtolnay@gmail.com>",
+]
+build = "build.rs"
+include = [
+ "build.rs",
+ "src/**/*.rs",
+ "crates-io.md",
+ "README.md",
+ "LICENSE-APACHE",
+ "LICENSE-MIT",
+]
+description = "A generic serialization/deserialization framework"
+homepage = "https://serde.rs"
+documentation = "https://docs.rs/serde"
+readme = "crates-io.md"
+keywords = [
+ "serde",
+ "serialization",
+ "no_std",
+]
+categories = [
+ "encoding",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/serde-rs/serde"
+
+[package.metadata.playground]
+features = [
+ "derive",
+ "rc",
+]
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+doc-scrape-examples = false
+
+[dependencies.serde_derive]
+version = "=1.0.152"
+optional = true
+
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[features]
+alloc = []
+default = ["std"]
+derive = ["serde_derive"]
+rc = []
+std = []
+unstable = []