summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tokio/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/tokio/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/tokio/Cargo.toml')
-rw-r--r--third_party/rust/tokio/Cargo.toml140
1 files changed, 140 insertions, 0 deletions
diff --git a/third_party/rust/tokio/Cargo.toml b/third_party/rust/tokio/Cargo.toml
new file mode 100644
index 0000000000..1141c07a83
--- /dev/null
+++ b/third_party/rust/tokio/Cargo.toml
@@ -0,0 +1,140 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.49"
+name = "tokio"
+version = "1.17.0"
+authors = ["Tokio Contributors <team@tokio.rs>"]
+description = "An event-driven, non-blocking I/O platform for writing asynchronous I/O\nbacked applications.\n"
+homepage = "https://tokio.rs"
+readme = "README.md"
+keywords = ["io", "async", "non-blocking", "futures"]
+categories = ["asynchronous", "network-programming"]
+license = "MIT"
+repository = "https://github.com/tokio-rs/tokio"
+[package.metadata.docs.rs]
+all-features = true
+rustc-args = ["--cfg", "tokio_unstable"]
+rustdoc-args = ["--cfg", "docsrs", "--cfg", "tokio_unstable"]
+
+[package.metadata.playground]
+features = ["full", "test-util"]
+[dependencies.bytes]
+version = "1.0.0"
+optional = true
+
+[dependencies.memchr]
+version = "2.2"
+optional = true
+
+[dependencies.mio]
+version = "0.8.0"
+optional = true
+
+[dependencies.num_cpus]
+version = "1.8.0"
+optional = true
+
+[dependencies.once_cell]
+version = "1.5.2"
+optional = true
+
+[dependencies.parking_lot]
+version = "0.12.0"
+optional = true
+
+[dependencies.pin-project-lite]
+version = "0.2.0"
+
+[dependencies.socket2]
+version = "0.4.4"
+features = ["all"]
+optional = true
+
+[dependencies.tokio-macros]
+version = "1.7.0"
+optional = true
+[dev-dependencies.async-stream]
+version = "0.3"
+
+[dev-dependencies.futures]
+version = "0.3.0"
+features = ["async-await"]
+
+[dev-dependencies.mockall]
+version = "0.10.2"
+
+[dev-dependencies.tempfile]
+version = "3.1.0"
+
+[dev-dependencies.tokio-stream]
+version = "0.1"
+
+[dev-dependencies.tokio-test]
+version = "0.4.0"
+
+[features]
+default = []
+fs = []
+full = ["fs", "io-util", "io-std", "macros", "net", "parking_lot", "process", "rt", "rt-multi-thread", "signal", "sync", "time"]
+io-std = []
+io-util = ["memchr", "bytes"]
+macros = ["tokio-macros"]
+net = ["libc", "mio/os-poll", "mio/os-ext", "mio/net", "socket2", "winapi/namedpipeapi"]
+process = ["bytes", "once_cell", "libc", "mio/os-poll", "mio/os-ext", "mio/net", "signal-hook-registry", "winapi/threadpoollegacyapiset"]
+rt = []
+rt-multi-thread = ["num_cpus", "rt"]
+signal = ["once_cell", "libc", "mio/os-poll", "mio/net", "mio/os-ext", "signal-hook-registry", "winapi/consoleapi"]
+stats = []
+sync = []
+test-util = ["rt", "sync", "time"]
+time = []
+[target."cfg(loom)".dev-dependencies.loom]
+version = "0.5.2"
+features = ["futures", "checkpoint"]
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.proptest]
+version = "1"
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.rand]
+version = "0.8.0"
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.socket2]
+version = "0.4"
+[target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
+version = "0.3.0"
+[target."cfg(target_os = \"freebsd\")".dev-dependencies.mio-aio]
+version = "0.6.0"
+features = ["tokio"]
+[target."cfg(tokio_unstable)".dependencies.tracing]
+version = "0.1.25"
+features = ["std"]
+optional = true
+default-features = false
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.42"
+optional = true
+
+[target."cfg(unix)".dependencies.signal-hook-registry]
+version = "1.1.1"
+optional = true
+[target."cfg(unix)".dev-dependencies.libc]
+version = "0.2.42"
+
+[target."cfg(unix)".dev-dependencies.nix]
+version = "0.23"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.8"
+optional = true
+default-features = false
+[target."cfg(windows)".dev-dependencies.ntapi]
+version = "0.3.6"