summaryrefslogtreecommitdiffstats
path: root/third_party/sqlite3/README
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/sqlite3/README
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--third_party/sqlite3/README39
-rw-r--r--third_party/sqlite3/README.MOZILLA13
2 files changed, 52 insertions, 0 deletions
diff --git a/third_party/sqlite3/README b/third_party/sqlite3/README
new file mode 100644
index 0000000000..0d65e518f9
--- /dev/null
+++ b/third_party/sqlite3/README
@@ -0,0 +1,39 @@
+This directory contains source code to
+
+ SQLite: An Embeddable SQL Database Engine
+
+To compile the project, first create a directory in which to place
+the build products. It is recommended, but not required, that the
+build directory be separate from the source directory. Cd into the
+build directory and then from the build directory run the configure
+script found at the root of the source tree. Then run "make".
+
+For example:
+
+ tar xzf sqlite.tar.gz ;# Unpack the source tree into "sqlite"
+ mkdir bld ;# Build will occur in a sibling directory
+ cd bld ;# Change to the build directory
+ ../sqlite/configure ;# Run the configure script
+ make ;# Run the makefile.
+ make install ;# (Optional) Install the build products
+
+The configure script uses autoconf 2.61 and libtool. If the configure
+script does not work out for you, there is a generic makefile named
+"Makefile.linux-gcc" in the top directory of the source tree that you
+can copy and edit to suit your needs. Comments on the generic makefile
+show what changes are needed.
+
+The linux binaries on the website are created using the generic makefile,
+not the configure script. The windows binaries on the website are created
+using MinGW32 configured as a cross-compiler running under Linux. For
+details, see the ./publish.sh script at the top-level of the source tree.
+The developers do not use teh configure script.
+
+SQLite does not require TCL to run, but a TCL installation is required
+by the makefiles. SQLite contains a lot of generated code and TCL is
+used to do much of that code generation. The makefile also requires
+AWK.
+
+Contacts:
+
+ http://www.sqlite.org/
diff --git a/third_party/sqlite3/README.MOZILLA b/third_party/sqlite3/README.MOZILLA
new file mode 100644
index 0000000000..6cbccb1e01
--- /dev/null
+++ b/third_party/sqlite3/README.MOZILLA
@@ -0,0 +1,13 @@
+This is the SQLite amalgamation.
+Check sqlite3.h for the version number and source id.
+
+See http://www.sqlite.org/ for more info.
+
+We have a mozilla-specific moz.build in src/ (normally no
+moz.build there) that we use to build.
+
+To move to a new version:
+
+Copy the sqlite3.h and sqlite3.c files from the amalgamation of sqlite.
+
+Be sure to update SQLITE_VERSION accordingly in $(topsrcdir)/configure.in.