summaryrefslogtreecommitdiffstats
path: root/devtools/client/debugger/src/components/test/A11yIntention.spec.js
diff options
context:
space:
mode:
Diffstat (limited to 'devtools/client/debugger/src/components/test/A11yIntention.spec.js')
-rw-r--r--devtools/client/debugger/src/components/test/A11yIntention.spec.js33
1 files changed, 33 insertions, 0 deletions
diff --git a/devtools/client/debugger/src/components/test/A11yIntention.spec.js b/devtools/client/debugger/src/components/test/A11yIntention.spec.js
new file mode 100644
index 0000000000..6a529b851d
--- /dev/null
+++ b/devtools/client/debugger/src/components/test/A11yIntention.spec.js
@@ -0,0 +1,33 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at <http://mozilla.org/MPL/2.0/>. */
+
+import React from "react";
+import { shallow } from "enzyme";
+import A11yIntention from "../A11yIntention";
+
+function render() {
+ return shallow(
+ <A11yIntention>
+ <span>hello world</span>
+ </A11yIntention>
+ );
+}
+
+describe("A11yIntention", () => {
+ it("renders its children", () => {
+ const component = render();
+ expect(component).toMatchSnapshot();
+ });
+
+ it("indicates that the mouse or keyboard is being used", () => {
+ const component = render();
+ expect(component.prop("className")).toEqual("A11y-mouse");
+
+ component.simulate("keyDown");
+ expect(component.prop("className")).toEqual("A11y-keyboard");
+
+ component.simulate("mouseDown");
+ expect(component.prop("className")).toEqual("A11y-mouse");
+ });
+});