summaryrefslogtreecommitdiffstats
path: root/devtools/client/debugger/src/utils/tests/function.spec.js
diff options
context:
space:
mode:
Diffstat (limited to 'devtools/client/debugger/src/utils/tests/function.spec.js')
-rw-r--r--devtools/client/debugger/src/utils/tests/function.spec.js61
1 files changed, 61 insertions, 0 deletions
diff --git a/devtools/client/debugger/src/utils/tests/function.spec.js b/devtools/client/debugger/src/utils/tests/function.spec.js
new file mode 100644
index 0000000000..7376aa1280
--- /dev/null
+++ b/devtools/client/debugger/src/utils/tests/function.spec.js
@@ -0,0 +1,61 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at <http://mozilla.org/MPL/2.0/>. */
+
+import { findFunctionText } from "../function";
+
+import { getSymbols } from "../../workers/parser/getSymbols";
+import { populateOriginalSource } from "../../workers/parser/tests/helpers";
+
+describe("function", () => {
+ describe("findFunctionText", () => {
+ it("finds function", () => {
+ const source = populateOriginalSource("func");
+ const symbols = getSymbols(source.id);
+ const text = findFunctionText(14, source, source.content, symbols);
+ expect(text).toMatchSnapshot();
+ });
+
+ it("finds function signature", () => {
+ const source = populateOriginalSource("func");
+ const symbols = getSymbols(source.id);
+
+ const text = findFunctionText(13, source, source.content, symbols);
+ expect(text).toMatchSnapshot();
+ });
+
+ it("misses function closing brace", () => {
+ const source = populateOriginalSource("func");
+ const symbols = getSymbols(source.id);
+
+ const text = findFunctionText(15, source, source.content, symbols);
+
+ // TODO: we should try and match the closing bracket.
+ expect(text).toEqual(null);
+ });
+
+ it("finds property function", () => {
+ const source = populateOriginalSource("func");
+ const symbols = getSymbols(source.id);
+
+ const text = findFunctionText(29, source, source.content, symbols);
+ expect(text).toMatchSnapshot();
+ });
+
+ it("finds class function", () => {
+ const source = populateOriginalSource("func");
+ const symbols = getSymbols(source.id);
+
+ const text = findFunctionText(33, source, source.content, symbols);
+ expect(text).toMatchSnapshot();
+ });
+
+ it("cant find function", () => {
+ const source = populateOriginalSource("func");
+ const symbols = getSymbols(source.id);
+
+ const text = findFunctionText(20, source, source.content, symbols);
+ expect(text).toEqual(null);
+ });
+ });
+});