summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ReadableStreamDefaultController.webidl
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--dom/webidl/ReadableStreamDefaultController.webidl22
1 files changed, 22 insertions, 0 deletions
diff --git a/dom/webidl/ReadableStreamDefaultController.webidl b/dom/webidl/ReadableStreamDefaultController.webidl
new file mode 100644
index 0000000000..0964d4b1d6
--- /dev/null
+++ b/dom/webidl/ReadableStreamDefaultController.webidl
@@ -0,0 +1,22 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#rs-default-controller-class-definition
+ */
+
+[Exposed=*]
+interface ReadableStreamDefaultController {
+ readonly attribute unrestricted double? desiredSize;
+
+ [Throws]
+ undefined close();
+
+ [Throws]
+ undefined enqueue(optional any chunk);
+
+ [Throws]
+ undefined error(optional any e);
+};