summaryrefslogtreecommitdiffstats
path: root/modules/libpref/init/static_prefs
diff options
context:
space:
mode:
Diffstat (limited to 'modules/libpref/init/static_prefs')
-rw-r--r--modules/libpref/init/static_prefs/Cargo.toml12
-rw-r--r--modules/libpref/init/static_prefs/src/lib.rs11
2 files changed, 23 insertions, 0 deletions
diff --git a/modules/libpref/init/static_prefs/Cargo.toml b/modules/libpref/init/static_prefs/Cargo.toml
new file mode 100644
index 0000000000..061bf92b48
--- /dev/null
+++ b/modules/libpref/init/static_prefs/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "static_prefs"
+version = "0.1.0"
+authors = ["Nicholas Nethercote <nnethercote@mozilla.com>"]
+edition = "2018"
+license = "MPL-2.0"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+mozbuild = "0.1"
+nsstring = { path = "../../../../xpcom/rust/nsstring" }
diff --git a/modules/libpref/init/static_prefs/src/lib.rs b/modules/libpref/init/static_prefs/src/lib.rs
new file mode 100644
index 0000000000..88975798ad
--- /dev/null
+++ b/modules/libpref/init/static_prefs/src/lib.rs
@@ -0,0 +1,11 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+//! This module contains getters for static prefs.
+//!
+//! The contents of this module are generated by
+//! `modules/libpref/init/generate_static_pref_list.py`, from
+//! `modules/libpref/init/StaticPrefList.yaml`.
+
+include!(mozbuild::objdir_path!("modules/libpref/static_prefs.rs"));