summaryrefslogtreecommitdiffstats
path: root/testing/geckodriver/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--testing/geckodriver/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/geckodriver/Cargo.toml b/testing/geckodriver/Cargo.toml
new file mode 100644
index 0000000000..4f2b60ce1b
--- /dev/null
+++ b/testing/geckodriver/Cargo.toml
@@ -0,0 +1,51 @@
+[package]
+edition = "2018"
+name = "geckodriver"
+version = "0.33.0"
+authors = ["Mozilla"]
+include = [
+ "/.cargo",
+ "/build.rs",
+ "/src"
+ ]
+description = "Proxy for using WebDriver clients to interact with Gecko-based browsers."
+readme = "README.md"
+keywords = [
+ "firefox",
+ "httpd",
+ "mozilla",
+ "w3c",
+ "webdriver",
+ ]
+license = "MPL-2.0"
+repository = "https://hg.mozilla.org/mozilla-central/file/tip/testing/geckodriver"
+
+[dependencies]
+base64 = "0.21"
+chrono = "0.4.6"
+clap = { version = "~3.1", default-features = false, features = ["cargo", "std", "suggestions", "wrap_help"] }
+hyper = "0.14"
+lazy_static = "1.0"
+log = { version = "0.4", features = ["std"] }
+marionette = { path = "./marionette", version="0.4.0" }
+mozdevice = { path = "../mozbase/rust/mozdevice", version="0.5.0" }
+mozprofile = { path = "../mozbase/rust/mozprofile", version="0.9.0" }
+mozrunner = { path = "../mozbase/rust/mozrunner", version="0.15.0" }
+mozversion = { path = "../mozbase/rust/mozversion", version="0.5.0" }
+regex = { version="1.0", default-features = false, features = ["perf", "std"] }
+serde = "1.0"
+serde_derive = "1.0"
+serde_json = "1.0"
+serde_yaml = "0.8"
+tempfile = "3"
+unicode-segmentation = "1.9"
+url = "2.0"
+uuid = { version = "1.0", features = ["v4"] }
+webdriver = { path = "../webdriver", version="0.48.0" }
+zip = { version = "0.6", default-features = false, features = ["deflate"] }
+
+[dev-dependencies]
+tempfile = "3"
+
+[[bin]]
+name = "geckodriver"