summaryrefslogtreecommitdiffstats
path: root/third_party/rust/arbitrary/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/arbitrary/Cargo.toml')
-rw-r--r--third_party/rust/arbitrary/Cargo.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/third_party/rust/arbitrary/Cargo.toml b/third_party/rust/arbitrary/Cargo.toml
new file mode 100644
index 0000000000..9b116114df
--- /dev/null
+++ b/third_party/rust/arbitrary/Cargo.toml
@@ -0,0 +1,50 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.63.0"
+name = "arbitrary"
+version = "1.2.3"
+authors = [
+ "The Rust-Fuzz Project Developers",
+ "Nick Fitzgerald <fitzgen@gmail.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Simonas Kazlauskas <arbitrary@kazlauskas.me>",
+ "Brian L. Troutwine <brian@troutwine.us>",
+ "Corey Farwell <coreyf@rwell.org>",
+]
+description = "The trait for generating structured data from unstructured data"
+documentation = "https://docs.rs/arbitrary/"
+readme = "README.md"
+keywords = [
+ "arbitrary",
+ "testing",
+]
+categories = ["development-tools::testing"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-fuzz/arbitrary/"
+
+[[example]]
+name = "derive_enum"
+required-features = ["derive"]
+
+[[test]]
+name = "derive"
+path = "./tests/derive.rs"
+required-features = ["derive"]
+
+[dependencies.derive_arbitrary]
+version = "1.2.3"
+optional = true
+
+[features]
+derive = ["derive_arbitrary"]