summaryrefslogtreecommitdiffstats
path: root/third_party/rust/askama_shared/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/askama_shared/Cargo.toml')
-rw-r--r--third_party/rust/askama_shared/Cargo.toml83
1 files changed, 83 insertions, 0 deletions
diff --git a/third_party/rust/askama_shared/Cargo.toml b/third_party/rust/askama_shared/Cargo.toml
new file mode 100644
index 0000000000..58629debea
--- /dev/null
+++ b/third_party/rust/askama_shared/Cargo.toml
@@ -0,0 +1,83 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "askama_shared"
+version = "0.12.2"
+description = "Shared code for Askama"
+homepage = "https://github.com/djc/askama"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/djc/askama"
+[package.metadata.docs.rs]
+features = ["config", "humansize", "num-traits", "json", "yaml", "percent-encoding"]
+[dependencies.askama_escape]
+version = "0.10.3"
+
+[dependencies.comrak]
+version = "0.12"
+optional = true
+default-features = false
+
+[dependencies.humansize]
+version = "1.1.0"
+optional = true
+
+[dependencies.mime]
+version = "0.3"
+
+[dependencies.mime_guess]
+version = "2"
+
+[dependencies.nom]
+version = "7"
+
+[dependencies.num-traits]
+version = "0.2.6"
+optional = true
+
+[dependencies.percent-encoding]
+version = "2.1.0"
+optional = true
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+
+[dependencies.serde_yaml]
+version = "0.8"
+optional = true
+
+[dependencies.syn]
+version = "1"
+
+[dependencies.toml]
+version = "0.5"
+optional = true
+
+[features]
+config = ["serde", "toml"]
+default = ["config", "humansize", "num-traits", "percent-encoding"]
+json = ["serde", "serde_json", "askama_escape/json"]
+markdown = ["comrak"]
+yaml = ["serde", "serde_yaml"]