summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bhttp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/bhttp/Cargo.toml')
-rw-r--r--third_party/rust/bhttp/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/third_party/rust/bhttp/Cargo.toml b/third_party/rust/bhttp/Cargo.toml
new file mode 100644
index 0000000000..9b3a01d305
--- /dev/null
+++ b/third_party/rust/bhttp/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "bhttp"
+version = "0.3.1"
+authors = ["Martin Thomson <mt@lowentropy.net>"]
+description = "Binary HTTP messages (draft-ietf-httpbis-binary-message)"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/martinthomson/ohttp"
+
+[dependencies.thiserror]
+version = "1"
+
+[dependencies.url]
+version = "2"
+optional = true
+
+[dev-dependencies.hex]
+version = "0.4"
+
+[features]
+bhttp = [
+ "read-bhttp",
+ "write-bhttp",
+]
+default = ["bhttp"]
+http = [
+ "read-http",
+ "write-http",
+]
+read-bhttp = []
+read-http = ["url"]
+write-bhttp = []
+write-http = []