summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bumpalo/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/bumpalo/Cargo.toml')
-rw-r--r--third_party/rust/bumpalo/Cargo.toml66
1 files changed, 66 insertions, 0 deletions
diff --git a/third_party/rust/bumpalo/Cargo.toml b/third_party/rust/bumpalo/Cargo.toml
new file mode 100644
index 0000000000..02ec679c2b
--- /dev/null
+++ b/third_party/rust/bumpalo/Cargo.toml
@@ -0,0 +1,66 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "bumpalo"
+version = "3.12.0"
+authors = ["Nick Fitzgerald <fitzgen@gmail.com>"]
+exclude = [
+ "/.github/*",
+ "/benches",
+ "/tests",
+ "valgrind.supp",
+ "bumpalo.png",
+]
+description = "A fast bump allocation arena for Rust."
+documentation = "https://docs.rs/bumpalo"
+readme = "README.md"
+categories = [
+ "memory-management",
+ "rust-patterns",
+ "no-std",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/fitzgen/bumpalo"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[lib]
+path = "src/lib.rs"
+bench = false
+
+[[test]]
+name = "try_alloc"
+path = "tests/try_alloc.rs"
+harness = false
+
+[[bench]]
+name = "benches"
+path = "benches/benches.rs"
+harness = false
+required-features = ["collections"]
+
+[dev-dependencies.criterion]
+version = "0.3.6"
+
+[dev-dependencies.quickcheck]
+version = "1.0.3"
+
+[dev-dependencies.rand]
+version = "0.8.5"
+
+[features]
+allocator_api = []
+boxed = []
+collections = []
+default = []