summaryrefslogtreecommitdiffstats
path: root/third_party/rust/chardetng_c/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/chardetng_c/Cargo.toml')
-rw-r--r--third_party/rust/chardetng_c/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/rust/chardetng_c/Cargo.toml b/third_party/rust/chardetng_c/Cargo.toml
new file mode 100644
index 0000000000..a4dbace3b2
--- /dev/null
+++ b/third_party/rust/chardetng_c/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "chardetng_c"
+version = "0.1.2"
+authors = ["Henri Sivonen <hsivonen@hsivonen.fi>"]
+description = "C bindings for chardetng"
+homepage = "https://docs.rs/chardetng_c/"
+documentation = "https://docs.rs/chardetng_c/"
+readme = "README.md"
+keywords = [
+ "encoding",
+ "web",
+ "unicode",
+ "charset",
+]
+categories = [
+ "text-processing",
+ "encoding",
+ "web-programming",
+ "internationalization",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/hsivonen/chardetng-c"
+
+[dependencies]
+chardetng = "0.1.1"
+encoding_rs = "0.8.17"