summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cose/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cose/Cargo.toml')
-rw-r--r--third_party/rust/cose/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/cose/Cargo.toml b/third_party/rust/cose/Cargo.toml
new file mode 100644
index 0000000000..5251eac5c2
--- /dev/null
+++ b/third_party/rust/cose/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "cose"
+version = "0.1.4"
+authors = ["Franziskus Kiefer <franziskuskiefer@gmail.com>", "David Keeler <dkeeler@mozilla.com>"]
+build = "build.rs"
+description = "Library to use COSE (https://tools.ietf.org/html/rfc8152) in Rust"
+keywords = ["cose", "jose"]
+license = "MPL-2.0"
+repository = "https://github.com/franziskuskiefer/cose-rust"
+
+[lib]
+name = "cose"
+path = "src/cose.rs"
+[dependencies.moz_cbor]
+version = "0.1.0"
+[dev-dependencies.scopeguard]
+version = "0.3"
+
+[features]
+default = []