summaryrefslogtreecommitdiffstats
path: root/third_party/rust/d3d12/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/d3d12/Cargo.toml62
1 files changed, 62 insertions, 0 deletions
diff --git a/third_party/rust/d3d12/Cargo.toml b/third_party/rust/d3d12/Cargo.toml
new file mode 100644
index 0000000000..4a04d077ba
--- /dev/null
+++ b/third_party/rust/d3d12/Cargo.toml
@@ -0,0 +1,62 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "d3d12"
+version = "0.6.0"
+authors = ["gfx-rs developers"]
+description = "Low level D3D12 API wrapper"
+documentation = "https://docs.rs/d3d12"
+readme = "README.md"
+keywords = [
+ "windows",
+ "graphics",
+]
+categories = [
+ "api-bindings",
+ "graphics",
+ "memory-management",
+ "os::windows-apis",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/gfx-rs/d3d12-rs"
+
+[package.metadata.docs.rs]
+default-target = "x86_64-pc-windows-msvc"
+
+[dependencies]
+bitflags = "1"
+
+[dependencies.libloading]
+version = "0.7"
+optional = true
+
+[dependencies.winapi]
+version = "0.3"
+features = [
+ "dxgi1_2",
+ "dxgi1_3",
+ "dxgi1_4",
+ "dxgi1_5",
+ "dxgi1_6",
+ "dxgidebug",
+ "d3d12",
+ "d3d12sdklayers",
+ "d3dcommon",
+ "d3dcompiler",
+ "dxgiformat",
+ "synchapi",
+ "winerror",
+]
+
+[features]
+implicit-link = []