summaryrefslogtreecommitdiffstats
path: root/third_party/rust/debugid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/debugid/Makefile')
-rw-r--r--third_party/rust/debugid/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/debugid/Makefile b/third_party/rust/debugid/Makefile
new file mode 100644
index 0000000000..f0670799d8
--- /dev/null
+++ b/third_party/rust/debugid/Makefile
@@ -0,0 +1,32 @@
+all: style lint test
+.PHONY: all
+
+check: style lint
+.PHONY: check
+
+build:
+ @cargo build
+.PHONY: build
+
+doc:
+ @cargo doc
+.PHONY: doc
+
+test:
+ @cargo test
+.PHONY: test
+
+style:
+ @rustup component add rustfmt --toolchain stable 2> /dev/null
+ cargo +stable fmt -- --check
+.PHONY: style
+
+format:
+ @rustup component add rustfmt --toolchain stable 2> /dev/null
+ @cargo +stable fmt
+.PHONY: format
+
+lint:
+ @rustup component add clippy --toolchain stable 2> /dev/null
+ @cargo +stable clippy --tests -- -D clippy::all
+.PHONY: lint