summaryrefslogtreecommitdiffstats
path: root/third_party/rust/error-chain/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/error-chain/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/error-chain/Cargo.toml b/third_party/rust/error-chain/Cargo.toml
new file mode 100644
index 0000000000..55ed9ac659
--- /dev/null
+++ b/third_party/rust/error-chain/Cargo.toml
@@ -0,0 +1,32 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "error-chain"
+version = "0.12.4"
+authors = ["Brian Anderson <banderson@mozilla.com>", "Paul Colomiets <paul@colomiets.name>", "Colin Kiegel <kiegel@gmx.de>", "Yamakaky <yamakaky@yamaworld.fr>", "Andrew Gauger <andygauge@gmail.com>"]
+description = "Yet another error boilerplate library."
+documentation = "https://docs.rs/error-chain"
+readme = "README.md"
+keywords = ["error"]
+categories = ["rust-patterns"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-lang-nursery/error-chain"
+[dependencies.backtrace]
+version = "0.3.3"
+optional = true
+[build-dependencies.version_check]
+version = "0.9"
+
+[features]
+default = ["backtrace", "example_generated"]
+example_generated = []