summaryrefslogtreecommitdiffstats
path: root/third_party/rust/futures-executor/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--third_party/rust/futures-executor/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/third_party/rust/futures-executor/Cargo.toml b/third_party/rust/futures-executor/Cargo.toml
new file mode 100644
index 0000000000..6faf14d217
--- /dev/null
+++ b/third_party/rust/futures-executor/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.45"
+name = "futures-executor"
+version = "0.3.26"
+description = """
+Executors for asynchronous tasks based on the futures-rs library.
+"""
+homepage = "https://rust-lang.github.io/futures-rs"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/futures-rs"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.futures-core]
+version = "0.3.26"
+default-features = false
+
+[dependencies.futures-task]
+version = "0.3.26"
+default-features = false
+
+[dependencies.futures-util]
+version = "0.3.26"
+default-features = false
+
+[dependencies.num_cpus]
+version = "1.8.0"
+optional = true
+
+[dev-dependencies]
+
+[features]
+default = ["std"]
+std = [
+ "futures-core/std",
+ "futures-task/std",
+ "futures-util/std",
+]
+thread-pool = [
+ "std",
+ "num_cpus",
+]